Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having trouble with VPNC on my newly installed Fedora 13 box. It fails with got delete for old connection, ignoring followed by no response from target. Searching did not yield a solution.

Beside this computer sits a seemingly identical Fedora 13 install (same version, same updated packages). They are connected to the NAT switch going to the same remote site (same vpnc conf file). The older install works: when the new one fails I can still connect the old one. I'm not trying to connect both at once, just one of them.

Below is the last bit of output from debug 3. What could possibly be different on the new machine that would cause this problem? Can it actually be the remote site somehow doing this (since I use a NAT my external IP would be the same, but perhaps there is other session information if recalls?)

  PARSING PAYLOAD type: 0c (ISAKMP_PAYLOAD_D)
   next_type: 00 (ISAKMP_PAYLOAD_NONE)
   length: 001c
   d.doi: 00000001 (ISAKMP_DOI_IPSEC)
   d.protocol: 01 (ISAKMP_IPSEC_PROTO_ISAKMP)
   d.spi_length: 10
   d.num_spi: 0001
   d.spi: 02ea31de 07e4e738 0a53a7d6 035d8706
   DONE PARSING PAYLOAD type: 0c (ISAKMP_PAYLOAD_D)

   PARSING PAYLOAD type: 00 (ISAKMP_PAYLOAD_NONE)
   PARSE_OK
   hashlen: 20
   u.hash.length: 20
   expected_hash:
   c85fdca3 77c77370 fb5171bf c522fb1e 173392ff
   h->u.hash.data:
   c85fdca3 77c77370 fb5171bf c522fb1e 173392ff
   got delete for old connection, ignoring..
vpnc: no response from target

The VPNC config looks like this (ids/keys replaced):

IPSec ID asdfasdf
IPSec gateway 1.1.1.1
IPSec secret asdfasdf
Xauth username asdfasdf
DPD idle timeout (our side) 0

I found on hint and also tried the below without success:

NAT Traversal Mode cisco-udp

Note I've also tried with various local port settings and it doesn't change anything. THe old system just runs with --local-port 0.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.