Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've set-up FileZilla server a Windows 2008 Machine, I then created the user, password and added a share folder which I set to Home Directory.

I then connect to the server from the client computer

Status: Connecting to {IP}
Status: Connection established, waiting for welcome message...
Response:   220-Welcome To {NAME} FTP
Response:   220 {DOMAIN}
Command:    USER {USER}
Response:   331 Password required for {USER}
Command:    PASS *********
Response:   230 Logged on
Status: Connected
Status: Retrieving directory listing...
Command:    PWD
Response:   257 "/" is current directory.
Command:    TYPE I
Response:   200 Type set to I
Command:    PASV
Response:   227 Entering Passive Mode ({}DATA)
Command:    MLSD

The connection works fine, however no remote directory is selected, it shows as "/" however uploading any file fails.

Any suggestions on how to debug this more?

share|improve this question

2 Answers 2

In user's window, there is tree type menu, In that select shared folders, Hope you set location of the ftp directory. There is some more options there with Files and Directories. Check all ticks.

It'll give you all permission for that user as default. It will work normally. If it's not working. You have to change directory permission on windows explorer (right click folder -> properties -> security).

share|improve this answer

Did you remember to assign "Write" permission to the user to their home directory in the Filezilla Server administration interface? Assuming you did be sure that the NTFS permissions on the home directory permit the Filezilla Server service write access there.

share|improve this answer
    
Write permission was granted. What user needs NTFS permision? –  LiamB May 5 '11 at 18:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.