Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have two servers with the versions above (9.00.4035.00 vs 9.00.1399.00), but we installed from the same source.

Now some projects don't open. How can I solve this - applying Service Pack 3?

share|improve this question

2 Answers 2

9.00.4035.00 is the build number for SQL Server 2005 SP3, 9.00.1399.00 is the build number for SQL Server 2005 RTM (release to market, ie- the first release). Applying SP3 to the RTM instance may solve your problem, but it's not guaranteed. If you can post more information about any errors you're getting we may be able to give you more.

You can make them both 9.00.4035 by installing SP3 to the 9.00.1399.00 server but, like DanBig mentions, SP4 is out so you should consider just installing SP4 on both servers. It is easy to do, just download the service pack and run its setup. Of course, make sure you have all the obvious things covered - full server backup, solid backups of all databases, etc.

Dowloads for SP3 and SP4:

Also, see How to identify your SQL Server version and edition.

share|improve this answer
    
For instance, apply SP3 didn't work. I couldn't get the errors yet. But I knew some projects doesn't open in the other server. Some of other MS products installed are different on both, maybe the VS use a component installed from other product version. –  Thomaz Portella May 5 '11 at 19:54
    
@Thomaz By "Projects", do you mean Visual Studio Database projects? What kind of projects are you referring to? –  squillman May 5 '11 at 20:16
    
Yes, VS 2008 projects. I will indicate to install SP4 in both and see what happens. The problem is stopping working in the two, now work in both , but only opens in that one. –  Thomaz Portella May 5 '11 at 20:35
    
I'll do this and see what happens. Txs. –  Thomaz Portella May 6 '11 at 12:20
    
I will make other question: How make the two 9.00.4035.00 or the two 9.00.1399.00 ? Is it easy do this ? –  Thomaz Portella May 6 '11 at 12:55

You should probably just install SP4 on both, as it's the latest update available.

share|improve this answer
    
I'll try this and see what happens. –  Thomaz Portella May 6 '11 at 12:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.