Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm working on setting up my first server on Linode.

I have:

  • installed apache
  • installed mysql
  • installed passenger
  • installed php
  • bunch of other things

I'm pretty sure my Passenger + rails is mostly working (have an error, but that's a different question, and at least passenger lets me know I have an error).

My issue is that non of the php is being run for the blog. Chrome just downloads the file.

Php is installed:

# php -v
PHP 5.3.3-1ubuntu9.3ppa1~lucid1 with Suhosin-Patch (cli) (built: Jan 15 2011 23:52:15) 
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
with Suhosin v0.9.31, Copyright (c) 2007-2010, by SektionEins GmbH

In my virtual host /etc/apache2/sites-available/MYDOMAIN.com I have:

<VirtualHost 173.255.244.242:80>
    ServerAdmin ryan@MYDOMAIN.com
    ServerName MYDOMAIN.com
    ServerAlias www.MYDOMAIN.com
    DocumentRoot /srv/www/MYDOMAIN.com/application/public
    ErrorLog /srv/www/MYDOMAIN.com/logs/error.log
    CustomLog /srv/www/MYDOMAIN.com/logs/access.log combined
</VirtualHost>

<VirtualHost 173.255.244.242:80>
    ServerAdmin ryan@MYDOMAIN.com
    ServerName blog.MYDOMAIN.com
    DocumentRoot /srv/www/blog.MYDOMAIN.com/public_html
    ErrorLog /srv/www/blog.MYDOMAIN.com/logs/error.log
    CustomLog /srv/www/blog.MYDOMAIN.com/logs/access.log combined
    <Directory /srv/www/blog.MYDOMAIN.com/public_html>
            PassengerEnabled off
            AllowOverride all
    </Directory>
</VirtualHost>

I thought this would turn off passenger on my blog and let PHP do its thing, but it doesn't seem to work that way. I know that is is pointing in the right spot because if I put a html file there it works and it downloads the php files. Any suggestions?

I'm running on Ubuntu 10.04.

share|improve this question

1 Answer 1

Looks like I just needed:

<VirtualHost *:80>
  ServerAdmin ryan@MYDOMAIN.com
  ServerName blog.MYDOMAIN.com
  DocumentRoot /srv/www/blog.MYDOMAIN.com/public_html
  ErrorLog /srv/www/blog.MYDOMAIN.com/logs/error.log
  CustomLog /srv/www/blog.MYDOMAIN.com/logs/access.log combined
    <Directory /srv/www/blog.MYDOMAIN.com/public_html>
       PassengerEnabled off
       Order allow,deny
       Allow from all
       AllowOverride all
    </Directory>
</VirtualHost>
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.