Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I would like to change mynetworks Postfix configuration parameter in Zimbra 7 on Debian GNU/Linux 5.0.

I tried the following (as zimbra user):

$ zmlocalconfig -e postfix_mynetworks="127.0.0.0/8 [...]"
$ postconf -e mynetworks="127.0.0.0/8 [...]"
$ zmmtactl reload
$ postfix check
$ postfix reload

However

$ postconf mynetworks

Shows still the old value! Anyone knows why and how to fix this? Thank you in advance

UPDATE After office hours I've even tried

# /etc/init.d/zimbra stop
# /etc/init.d/zimbra start

However the parameter is still not updated.

UPDATE 2

$ zmlocalconfig postfix_mynetworks

Shows the updated value

$ zmmtactl reload
Rewriting configuration files...
postfix/postfix-script: refreshing the Postfix mail system
Stopping saslauthd...done.
Starting saslauthd...done.

But sadly postconf mynetworks still shows the old value. Running again postconf -e sets the value and gets lost at the first postfix reload...

share|improve this question
1  
You can also change this in the Admin Console under Server Settings -> MTA -> MTA Trusted Networks. –  xeon May 6 '11 at 20:08
    
@xeon, thank you, that's a good suggestion, why don't you post it as an answer? –  stivlo May 7 '11 at 4:28
add comment

1 Answer

up vote 1 down vote accepted

I found the solution to my own problem. By looking at the file /opt/zimbra/conf/zmmta.cf, I saw the following lines:

if VAR zimbraMtaMyNetworks
    POSTCONF mynetworks VAR zimbraMtaMyNetworks
fi

With zmprov I can check the current settings and change them:

zmprov getServer servername.mydomain | grep zimbraMtaMyNetworks
zmprov modifyServer servername.mydomain zimbraMtaMyNetworks "127.0.0.0/8 [...]"
postfix reload

And the problem is solved. Xeon suggested an alternative and simpler way:

You can also change this in the Admin Console under Server Settings -> MTA -> MTA Trusted Networks

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.