Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a subversion installation running on a remote server which I manage myself. It worked just fine for a few weeks already and there were no changes in DNS or subversion configuration, but since yesterday I'm unable to commit/update anything. The error message I'm getting is:

Olgas-MacBook-Pro:ingenix olgary$ svn update svn: OPTIONS of 'http://mysvnhost/myproject/trunk': Could not resolve hostname `svn.logicaldesign.ru': Host not found (http://mysvnhost)

When I try to ping the host I get:

Olgas-MacBook-Pro:ingenix olgary$ ping mysvnhost ping: cannot resolve mysvnhost: Unknown host

The situation is that from OTHER computers everything is working just fine, no problems at all. Seems the problem is on my end... I've tried to reboot, execute "dscacheutil -flushcache" command, but nothing helped. Have no idea what else I can do. Any help will be greatly appreciated... Thank you in advance!

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Is it possible that you a hosts file referencing an old ip address?

Here's how to edit the hosts file.

share|improve this answer
    
Hi Cris! I did not have any mentioning of my domain in my hosts file, so what I did is added a row for it. I know this may be just a temporary workaround, but at least I can continue my work and commit files to svn. Thank you for the hint! –  Olga May 7 '11 at 1:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.