Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've installed Munin on CentOS, in Munin directory, it only has a few files and I could not see the website data. The Munin log shows the connection to 127.0.0.1 was refused. I have tried to disable iptables and it gives the same error.

Error log

2011/05/06 15:30:01 Opened log file
2011/05/06 15:30:01 [INFO]: Starting munin-update
2011/05/06 15:30:02 Failed to connect to node 127.0.0.1:4949/tcp : Connection refused
2011/05/06 15:30:02 [ERROR] Munin::Master::UpdateWorker failed to connect to node
2011/05/06 15:30:02 [INFO] Reaping Munin::Master::UpdateWorker. Exit value/signal: 20/0
2011/05/06 15:30:02 [INFO] No old data available for failed worker localhost;localhost. This node will disappear from the html web page hierarchy
2011/05/06 15:30:02 [INFO]: Munin-update finished (0.02 sec)

Munin directory

-rw-r--r-- 1 munin munin 2.5K May 6 15:05 definitions.html
-rw-r--r-- 1 munin munin 2.0K May 6 15:05 favicon.ico
-rw-r--r-- 1 munin munin 1.8K May 6 15:05 logo-h.png
-rw-r--r-- 1 munin munin 473 May 6 15:05 logo.png
-rw-r--r-- 1 munin munin 5.3K May 6 15:05 style.css

share|improve this question
1  
Do you have munin-node running? (/etc/init.d/munin-node start) –  Viktor Stískala May 6 '11 at 22:43
    
I only have one machine, isn't munin-node for multiple machines? –  garconcn May 6 '11 at 22:44
2  
You need munin-node on every machine you want to monitor. Even if you have only one node you want to monitor. –  Raffael Luthiger May 6 '11 at 22:50
    
Thank you. This solved the problem. The instruction in Linode wiki gave the wrong information. library.linode.com/server-monitoring/munin/fedora-14 –  garconcn May 6 '11 at 22:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.