Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've setup svnserve with SASL authentication and encryption for encrypting the traffic. Anonymous access should be allowed. My configuration file conf/svnserve.conf (with comments stripped) looks like this:

[general]
anon-access = read
auth-access = write
realm = realm-of-repo

[sasl]
use-sasl = true
min-encryption = 128
max-encryption = 256

The related sasl configuration file:

pwcheck_method: auxprop
auxprop_plugin: sasldb
sasldb_path: /path/to/sasldb
mech_list: DIGEST-MD5

When supplying an username and password, everything works as expected: I can checkout and make changes. However, anonymous access (no username or password) fails with the next error message:

svn: SASL(-1): generic failure: All-whitespace username.

How do I enable anonymous SVN read access using svnserve and SASL ? I'm not looking for a solution with Apache.

share|improve this question
add comment

1 Answer

The use-sasl = true forces authentification (tells SVN to prohibit anonymous access).

You could either create a user with read-only privileges and use it for anonymous access or use http for read-only access and sasl for read-write.

share|improve this answer
    
I would like to avoid HTTP for performance reasons. How would I add anonymous access? –  Lekensteyn May 7 '11 at 10:22
    
You can't allow anonymous access with use-sasl = true. A little workaround here is to create a user called "guest" or similar with read-only access and provide its credentials to your users for anonymous access. –  Viktor Stískala May 7 '11 at 10:45
    
how would I add a read-only user in SASL? The only options I can pass to sasldbpass2 are realm and username. –  Lekensteyn May 7 '11 at 11:49
    
I was convinced that you can create groups with different privileges, but this probably works only with mod_authz_svn. Sorry, my bad. –  Viktor Stískala May 7 '11 at 20:25
    
On mailing lists and fora I see indeed declining messages on anonymous access with SASL. Thanks for your answer anyway. –  Lekensteyn May 7 '11 at 20:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.