Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a weird problem I'm trying to solve, but can't find out how. I found that problem when trying to access a php page and only the basic html and css were loaded but the flash didn't. when I tried to download the swf file directly, I encountered an http timeout error.

In order to find the problem I ran some tests: 1) when I downloaded a file via FTP, the download speed was ok. 2) when I downloaded a BIG file (100M) via http - the download speed also was ok. 3) when I downloaded a small file (50K) via http - the download speed was very slow. I tried several file extensions but it gave the same result. This is the reason for the flash swf file to not load successfully - due to a timeout.
Edit: the file is downloaded, but corrupted since data is missing in the middle of the file

The most interesting part is that when I access the same page via localhost or outside of the network (s.a via ppp interface over cellular modem) the files are loaded perfectly. Therefore, the problem is only for LAN.

The server is apache2, over Ubuntu 10.04.

Any ideas?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

It sounds more like some sort of LAN issue, either the network itself, the client machine, or the server. This is supported by you mentioning you are getting corrupted data in the middle of the file assumably over the LAN but not localhost/PPP.

I would try and narrow down the issue. A few things you can check:

  • Is it just HTTP or all other services being affected on the LAN?
  • Is it just this one server or all machines on the LAN?
  • Is it just outgoing data or incoming data?
  • Are there any relevant log messages (Apache, boot-up, system, etc...)?
  • Are there any firewalls (software/hardware) on the LAN that might be causing an issue?

Don't ignore the possibility of rare things like bad hardware (network card, router, switch, cable, etc...).

share|improve this answer
add comment

Only for LAN but not with "localhost" or over PPP? Sounds like a resolving issue to me. Check your DNS-settings on the server: e.g. /etc/resolv.conf, local running BIND-server and look for wrong entries in /etc/hosts

share|improve this answer
    
i'm not connecting via DNS, but only by IP. does it still counts? –  Irit Malka May 8 '11 at 9:29
    
Yes, it still counts. –  Henk May 8 '11 at 9:34
    
can you please specify what might be a wrong entry in those /etc/hosts? –  Irit Malka May 8 '11 at 12:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.