Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have upgraded my OS from AIX5.3 to AIX6.1, now i need to upgrade the Technology Level The current version is the following:
root@myserver:/:>oslevel -s
6100-02-01-0847
root@myserver:/:>oslevel -sq
Known Service Packs

6100-04-07-1036
6100-04-06-1034
6100-04-05-1015
6100-04-04-1014
6100-04-03-1009
6100-04-02-1007
6100-04-01-0944
6100-03-07-1036
6100-03-06-1034
6100-03-05-1015
6100-03-04-1014
6100-03-03-0943
6100-03-02-0939
6100-03-01-0921
6100-02-10-1036
6100-02-09-1034
6100-02-08-1015
6100-02-07-1014
6100-02-06-0943
6100-02-05-0939
6100-02-04-0920
6100-02-03-0909
6100-02-02-0849
6100-02-01-0847
6100-02-00-0000
6100-01-09-1015
6100-01-08-1014
6100-01-07-0943
6100-01-06-0939
6100-01-05-0920
6100-01-04-0909
6100-01-03-0846
6100-01-02-0834
6100-01-01-0823
6100-00-11-0943
6100-00-10-0939
6100-00-09-0920
6100-00-08-0909
6100-00-07-0846
6100-00-06-0834
6100-00-05-0822
6100-00-04-0815
6100-00-03-0808
6100-00-02-0750
6100-00-01-0748
My Question to which TL i can jump from the existing one.?
Thank you

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I would recommend the newest one (6100-06-04-1112), which you can download from Fix Central web site ( http://www-933.ibm.com/support/fixcentral/ ).

Take a look at e.g. http://www.ibm.com/developerworks/aix/library/au-aixtlupdate/index.html to see possible TL update strategies.

If you want to determine what you have currently installed, then run instfix -i|grep SP. This will tell you for which TLs you have complete filesets, and for which not. The list of filesets missing to form a complete TL run instfix -ciqk 5200-09-01_SP|grep ":-:"

Caveats: make sure your TL download is complete. I had problems with truncated files, which then wedged upgrade process. Also double check that you have no exotic software that wouldn't cooperate with a changed TL. Then see if your firmware, HMC, PowerHA/HACMP is compatible with the new TL.

share|improve this answer
    
thank you for answering my question. Iwas able to install this:6100-06-02-1044 my question: when i run lppchk -v this is the output: lppchk: The following filesets need to be installed or corrected to bring devices.pciex.b3154a63.rte 5.3.10.1 (usr: not installed, root: COMMITTED) devices.pciex.b3154a63.rte 5.3.10.4 (usr: not installed, root: COMMITTED). how can i resolve this? –  AlBouazizi May 9 '11 at 7:14
    
Hm... looks like you still have 5.3 filesets on the machine, and that they are broken. You may try to overwrite them using highest level of base media (not update media) that you have (preferrably 6100-something), then update to your current TL. Option 2 would be to remove them, then re-install. Option 3 (safest) would be to call support for a procedure. Whichever way you choose make sure you have a current mksysb and can recover from a possible failure (or do an alt_disk_copy if you have spare storage and work on a clone of your rootvg). –  Paweł Brodacki May 9 '11 at 10:04
    
Thank you for answering –  AlBouazizi May 10 '11 at 14:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.