Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Many times google alert me that abuse content or phising is installed in my website.

But looking about it there is nothing on my public folder on my server. I see that the referral url is on my domain, but to a trailing wildcard url like: example.com/~alifer/paypal/index.php This on linux apache shared hosting is referred to a website and folder that is not mine!

So is there a way on a shared hosting server to disable or to protect my domain example.com not to accept ~ wildcard?

share|improve this question

1 Answer 1

You need to disable mod_userdir.

Summary: This module allows user-specific directories to be accessed using the http://example.com/~user/ syntax.

sudo a2dismod mod_userdir

sudo /etc/init.d/apache2 restart

share|improve this answer
    
But Im on a sharing plain server not managed by me. Can I do this / have access? Also could this lead not to serve well other shared websites in server folders? Do you think I can ask my provider to do this? Thanks for your reply. –  Chris V May 10 '11 at 18:44
    
Since you are on a shared server your host will have to disable it. I would defiantly ask your provider. There is a good chance they will disable it. –  Hawk May 12 '11 at 3:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.