Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm setting up a WAMP server with SSL on XP SP2.

-Default port 80 && 443 are NOT forwarded.

The server's admin forwarded ports 1000-1010 && 8080.

When I change httpd config file to listen to port 8080 for regular HTTP && SSL on 1001

8080 - Brings me to a routers/gateway login screen. 1001 - "SSL received a record that exceeded the maximum permissible length"

This is my first time setting up a HTTP/S server.

Localhost works perfectly. I'm not setting up Virtualhosts because I'm NOT wanting to connect to this via DNS.

share|improve this question

closed as off-topic by Tom O'Connor Aug 14 '13 at 21:08

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is a site dedicated to professionals; novice questions are off-topic. Please see the Help Center for more information on topicality. The best advice we can give you is to hire a professional to help you out." – Tom O'Connor
If this question can be reworded to fit the rules in the help center, please edit the question.

    
WAMP should be used for development only. You're asking to get hacked if you expose it to the internet (which is what you're trying to do). –  EEAA May 9 '11 at 2:07

1 Answer 1

I agree with ErikA. You should never put a WAMP server in the wild. Its fine to run on the Intra-net. Fine for business applications. Fine for development work. But we live in a world where this is a small challenge to crackers.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.