Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have enabled Named Pipes and TCP/IP for this instance and restarted the service. I have also made sure the the port on the server is open on the firewall. I have also made sure that I have the correct credentials, I can access the server fine if I remote into the box, I just cannot access it over the network.

This SQL2008 R2 instance is installed on a server that has been running SQL 2008 for a while now. Has anyone else had this problem where the 2008R2 instance is still not available over the network?

  • Edit:

OS is Server 2008 R2 Standard. SQL 2008 R2 is a named Instance and the default SQL2008 instance is a default instance. Port is use is 1433(Default SQL port)

share|improve this question
add comment

1 Answer

Have you tried disabling windows firewall to verify this is not stopping communication with required port(s)?

I have found this is normally the issue for my remote connectivity issues when I have ensured all other settings have been done and the service restarted.

The other thing to try is to ensure the SQL Browser service is running.

You may want to give a bit more information about OS being used, whether your install is the default or named instance and just what services/ports are open to further allow diagnosis.

share|improve this answer
    
disabling the firewall entirely may get me into some trouble, will speak to the IT manager to confirm. SQL Browser service is also running. –  StevenMcD May 9 '11 at 10:00
    
A 1 minute test is all that's needed just to identify it is/is not the issue. Also, you are aware that if you don't specify a port that the ports will be dynamic with named instances? So default is 1433 and named maybe 1434.... –  Wayne May 9 '11 at 10:18
    
Port has been specified as 1433 in the Surface config manager and dynamic ports has been disabled. Thanks –  StevenMcD May 9 '11 at 11:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.