Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I don'y know what is going on. My dedicated server runs Cent OS 5.6 x86_64. It has been running for over a year pretty well. I also never had any disk failure. (Or I have never knew about any disk failure). The disks are in RAID, so, i'm not sure, but its possible the data center could have replaced a disk without I knowing that.

The fact is that some days ago, strange things started do happen. Server Load gets high, even when there is just a few requests/sec, and some httpd processes eats 100% cpu.

Other times, "top" doesn't show processes causing high server load, but the "Service Status" page on whm, shows high load.

Other thing that happened also, is that the server sometimes looks very slow to access whm or SSH, but I can access the websites hosted on it, and they load pretty fast, like if everything was normal, even with a high load.

Now, the Server Load, is about 40.

One strange thing that I noticed, is the "Blocks Written/Sec"

Blocks Read/sec =  1607.11
Blocks Written/Sec = 11836.01

I think the Blocks Written/Sec is higher then normal. The server hosts a popular photo effects website, so it gets a lot of traffic, but I think its strange...

Apache is optimized, with the same configurations, and the same visitors that the server was before the problems started.

What can be causing this?

share|improve this question
2  
Output of top and iostat might be helpful. –  uesp May 9 '11 at 15:50
    
"The disks are in RAID, so, i'm not sure, but its possible the data center could have replaced a disk" - it may became pertinent later on, but whenever you say "Raid" you have to specify "what kind of raid" –  Gavin C May 9 '11 at 15:58
    
In addition to uesp's suggestions, "iotop" maybe a useful util here to see what if anything is thrashing. –  Gavin C May 9 '11 at 18:48
add comment

1 Answer

If they are an md RAID set, then the periodic RAID resync can cause high loads and poor responsiveness. If you think this might be the cause, do a cat /proc/mdstat and look for messages about resyncing or checks in progress. I would paste an example but none of my servers are doing a resync right now, and I'd rather not kick off a terabyte resync just for the screen output.

share|improve this answer
    
hello. I got just Personalities : unused devices: <none> –  valter May 10 '11 at 11:25
    
OK, thanks for that. It's not an md RAID set, so my suggestion doesn't apply. Sorry. –  MadHatter May 10 '11 at 16:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.