Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have been given the responsibility of looking after a server with Red Hat Enterprise Linux (RHEL) AS release 3, with a USB external 500Gb hard disc, (Freecom part # 28604), it has failed in a strange way.

Ideally I would like to fix the drive or at least wipe it and be able to use it.

To start with the hard drive was mounted but the files that were on it had disappeared, when I tried to create a file (even with touch) it says :

Read-only file system

A df command shews that it is not empty. This is the mtab entry for the drive :

/dev/sdb1 /mnt/usbhd ext3 rw 0 0

Any thoughts as to how to resolve this?

What I have tried so far :

Ran fsck.ext3 -n /mnt/usbhd, it says :

e2fsck 1.32 (09-Nov-2002)
fsck.ext3: Attempt to read block from filesystem resulted in short read while trying to open /mnt/usbhd
Could this be a zero-length partition?

I then umounted it and ran fsck /dev/sdb1 :

fsck 1.32 (09-Nov-2002)
e2fsck 1.32 (09-Nov-2002)
fsck.ext2: No such device or address while trying to open /dev/sdb1
Possibly non-existent or swap device?

fdisk -l does not shew the device, however it is shewn in /proc/partitions, I have found an entry in /log/messages :

May 10 10:40:51 server4 devlabel: The device /dev/sdb1 is being put in devlabel's
temporary ignore list /etc/sysconfig/devlabel.d/ignore_list to avoid errors.
May 10 10:50:14 server4 devlabel: The device /dev/sdb1 is being put in devlabel's
temporary ignore list /etc/sysconfig/devlabel.d/ignore_list to avoid errors.

and the dmesg command returns a few errors relating to the device, this is a sample :

I/O error: dev 08:11, sector 66984
I/O error: dev 08:11, sector 4360
EXT3-fs error (device sd(8,17)): ext3_readdir: directory #2 contains a hole at o ffset 0
I/O error: dev 08:11, sector 0
I/O error: dev 08:11, sector 264
EXT3-fs error (device sd(8,17)): ext3_get_inode_loc: unable to read inode block - inode=2, block=33
I/O error: dev 08:11, sector 0
EXT3-fs error (device sd(8,17)) in ext3_reserve_inode_write: IO failure
I/O error: dev 08:11, sector 0
I/O error: dev 08:11, sector 4360
ext3_abort called.
EXT3-fs abort (device sd(8,17)): ext3_journal_start: Detected aborted journal
Remounting filesystem read-only
usb.c: USB disconnect on device 00:1d.7-5 address 3
hub.c: new USB device 00:1d.7-5, assigned address 4
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 4

share|improve this question
    
@SvenW - Added output –  Tim the Enchanter May 10 '11 at 8:09
    
I am stuck should I put an entry in /etc/fstab, there is no entry for that device? Is there anything else I should check? –  Tim the Enchanter May 10 '11 at 9:56
add comment

2 Answers

up vote 0 down vote accepted

it could be happen because of the device ejected, fs corrupted.

try to unmount and fsck /dev/sdb1 if still happen, try to unplug and plug the usb cable (or using different port)

share|improve this answer
    
G I have tried your suggestion without success. –  Tim the Enchanter May 10 '11 at 10:51
add comment

Most likely a broken file system. I hope you have a backup.

Well, anyway, here is how to check the file system:

fsck.ext3 -n /mnt/usbhd 

Please give us the output of this program (or a summary thereof).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.