Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a 1 year old Dell laptop running Windows 7 Pro 32 bit.

Last week, the PC started refusing to obtain an IP address via DHCP, but this only happens on the Wired Ethernet connection. The PC is assigned an APIPA address in the 169.XXX.XXX.XXX range. However, if I manually assign an IP address, the connection works fine.

If I switch over to wireless, the PC is able to obtain an IP address via DHCP just fine. The WAP which it is connecting to is on the same network as the DHCP server (a Netgear DG834 ADSL Modem router).

The network is a simple Windows network (no domain, active directory, etc).

I've tried connecting the laptop to different network points around the office, and even directly into the ADSL router, and it doesn't make a difference.

All indications suggest that there is something wrong in the Windows Networking stack on this machine.

Please help.

UPDATE: It's worth pointing out that we changed the router (and thus DHCP server) from a Siemens Gigaset to the current DG834 router on the same day. No other machines on our our network of 40+ devices were affected by the change. It's possible that the problem could be related to this, though I can't see how.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

I would reset the Windows Socket with the command

netsh winsock reset

executed in an cmd with administrator rights.

If this doesn't work I would check if there are free IP-Addresses, the router can assign or if all addresses have been assigned to clients?

Furthermore you could boot with a Linux Live-CD or use another router to check if Windows, your NIC or the router is the source of your problem.

share|improve this answer
    
Thanks. Going to try the winsock reset command. –  Saajid Ismail May 10 '11 at 10:00
    
another good netsh command is netsh int ip reset resetlog.txt. forces all network adapters back to DHCP clears any and all settings. –  SpacemanSpiff May 10 '11 at 12:05
    
Thanks Masterlan. In the end the problem "seemed" to have been on the router's DHCP server. I increased the range of IP-addresses that DHCP could dish out from, and that solved the problem. Quite strange though, as it was assigning addresses to the Wireless adapter on the same PC without problem. Sounds like the DHCP server might have been remembering each adapter's MAC address and wanting to assign the same address each time, and when it found that the address was already in use by someone else, it didn't respond. The only logical conclusion I can come to. Thanks for the advice. –  Saajid Ismail May 10 '11 at 14:17
add comment

It might be a firewall problem that is blocking DHCP - you could try

  • turning off the firewall briefly for a few seconds to see if that fixes it (if you are paranoid, disconnect your internet connection from your router)

  • installing Microsoft Network Monitor and seeing what packets are being sent / received

You can get DHCP to attempt to get a lease by opening a command prompt (as Administrator) and using the commands

ipconfig /release
ipconfig /renew
share|improve this answer
    
Hi. I've tried the above already. Disabled both anti-virus and my firewall. Hasn't made a difference. Tried to do an /release then /renew, and no difference either. –  Saajid Ismail May 10 '11 at 9:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.