Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Maybe it is because I am lacking in free disk space, take a look:

Filesystem            Size  Used Avail Use% Mounted on
/dev/sda2             1.9G  208M  1.6G  12% /
none                  998M  192K  998M   1% /dev
none                 1002M     0 1002M   0% /dev/shm
none                 1002M   56K 1002M   1% /var/run
none                 1002M     0 1002M   0% /var/lock
none                 1002M     0 1002M   0% /lib/init/rw
/dev/sda1              92M   24M   63M  28% /boot
/dev/sda8             434G  199M  412G   1% /home
/dev/sda6             9.2G  495M  8.3G   6% /usr
/dev/sda7             9.2G  8.8G     0 100% /var

/var is at 100% utilization.

Perhaps this is the reason?

share|improve this question
add comment

5 Answers

up vote 5 down vote accepted

Yes, it could be the reason if mysql's data is on /var/ (which is usually true).

It seems you have enough on /home/. Why don't copy data files there and try?

share|improve this answer
    
/var/log/apache2 -> ls -l -rw-r----- 1 root adm 12664832 2011-05-10 09:10 access.log -rw-r----- 1 root adm 71266773 2011-05-08 06:25 access.log.1 apache2 log files are rly big... maybe it could be the reason. how can i fix it? –  Mdjdzjds May 10 '11 at 12:23
    
i fixed it doing tail -1 access.log > access.log on /var/log/apache2. –  Mdjdzjds May 10 '11 at 12:39
    
Good Bounty Hunting !!! –  RolandoMySQLDBA May 20 '11 at 16:52
add comment

According to MySQL 5.0 Certification Study Guide, page 409, Chapter 29, section 29.2 "The MyISAM Engine", bullet point 11 specifically states:

If you run out of disk space while adding rows to a MyISAM table, no error occurs. The server suspends the operation until space becomes available, and then completes the operation.

Over and over again, whenever I see this occur, I delete a couple of old binary logs, and voilà, MySQL starts moving again. I then quickly shutdown MySQL, erase the remaining binary logs and the binary log index, start MySQL up, and everything is just fine. Works every time for me!

If binary logs are not enabled, then you have to use kill -9 on mysqld, move the /var/lib/mysql folder to a bigger disk. Symlink /var/lib/mysql to the new location, and start MySQL back up.

share|improve this answer
add comment

Yes it could be the reason.I think Your Mysql Data directory is in the /var.You please open your my.cnf(may be you can find it in /etc directory) file and check whether the data directory in /var or not.

I think so much space is available in /Home directory and you can use it as your mysql data directory.

share|improve this answer
add comment

Yes.

MySQL data files are usually kept in /var/ somewhere. If it's full, MySQL might stop working.

share|improve this answer
add comment

you can see usage by directory with

du -shc /var/*

then maybe:

du -shc /var/lib/mysql/*

to see db occupation on filesystem

-s summary

-h human (mb gb etc but not sortable)

-c prints the total at the end

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.