Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hey there, I'm currently having problems installing proftpd correctly.

At some point the pakage was already installed but when I try to install don't get a selection screen to preconfigure the server neither are any config files created.

I already tried to purge/reinstall/install/remove/clean/autoclean via apt-get but nothing seems to fix the problem.

Is there a way to force a "clean/fresh" install?

share|improve this question
up vote 5 down vote accepted

Alright I fixed it. The config files where bound to another package (proftpd-basic).

So using the following commands fixed the problems:

apt-get purge proftp*
apt-get install proftpd
share|improve this answer
Note that you can use apt-get purge in place of apt-get remove --purge. That's unless you are using a very old version of APT (older than mid-2007). – Tshepang May 10 '11 at 15:31
@Tshepang urghs I probably should look at the date of the posts I read more often - thanks :) – Flatlin3 May 10 '11 at 18:45
How is it that the simple solutions always go un-noticed? I was just beating my head against the desk trying to remove samba. Thanks for the tip. – Mr. Shickadance Oct 26 '11 at 14:43

Purge and install should work, so you may have some more severe underlying problem.

You may also try:

dpkg-reconfigure proftpd

and see what results you get.

share|improve this answer

To reinstall:

apt-get install --reinstall proftpd

If this does not work, uninstall, remove all its configuration, and install again:

apt-get remove --purge proftpd
rm -rf /etc/proftpd
apt-get install proftpd
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.