Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a website www.example.com and it works fine everywhere except when using 3g on my iphone, even works on Edge network. I have installed ping on my iphone and when on 3g it is says unable to DNS lookup host address. I do not have an A record for www.example.com, instead have a cname to an ELB on Amazon. I did try a test and added an A record for a subdomain test.example.com and that did work on 3g. So to me either Att has some DNS issues on 3g or it only works with an A record. Any help would be great. One other thing I can get to the site over 3g if I go directly to the ELB, which really makes me think its DNS, I just dont know where to go from here as its been 3 days now. Thanks

share|improve this question
    
I used the ip and it resolves so it's a dns issue with them. I am unable to change dns provider on my iPhone. It's been messed up for 3 days what can I do? –  user81021 May 10 '11 at 18:17
    
What is the TTL (time to live) setting on the DNS records? –  KJ-SRS May 10 '11 at 18:23
    
14400, I have waited much more than that. I also added a sub domain like i mentioned with an a record and that showed up within 4 hours –  Scott May 10 '11 at 19:24
    
no its 14400 seconds –  Scott May 11 '11 at 18:00

2 Answers 2

Its an issue related to the dualstack implementation on AT&T's DNS servers. Try creating a CNAME record using the IPv4 (first entry in the list) domain listed in AWS ELB settings.

enter image description here

share|improve this answer

That's a DNS issue at AT&T; they're probably using different resolvers for 3G vs. EDGE.

Try browsing to your site using just the IP first to make sure it's not a routing issue, of course, but if ping is reporting a failure on lookup then it's assuredly a DNS issue. Probably. (Unless it's having issues routing to the resolvers, in which case you'd notice a LOT more weirdness.)

If your phone supports it, you may want to change your resolvers. Google has a public resolver, 8.8.8.8

I prefer using Level3's public resolvers, because they report true NXDOMAIN instead of a redirect for nonexistent DNS records:

4.2.2.1
4.2.2.2
4.2.2.3

HTH

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.