Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

A Windows 2003 update messed up my server bad, so I had to reinstall .net v2. Now I can't access any .aspx pages (html load fine). When I try, I get the following error:

Server Error in '/' Application.

System.ServiceModel.Diagnostics.DiagnosticTrace..ctor(System.ServiceModel.Diagnostics.TraceSourceKind, System.String, System.String)

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.MethodAccessException: System.ServiceModel.Diagnostics.DiagnosticTrace..ctor(System.ServiceModel.Diagnostics.TraceSourceKind, System.String, System.String)

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[MethodAccessException: System.ServiceModel.Diagnostics.DiagnosticTrace..ctor(System.ServiceModel.Diagnostics.TraceSourceKind, System.String, System.String)]
System.ServiceModel.DiagnosticUtility.InitDiagnosticTraceImpl(TraceSourceKind sourceType, String traceSourceName) +0 System.ServiceModel.DiagnosticUtility.InitializeTracing() +13 System.ServiceModel.DiagnosticUtility..cctor() +89

[TypeInitializationException: The type initializer for 'System.ServiceModel.DiagnosticUtility' threw an exception.]
System.ServiceModel.Configuration.ConfigurationHelpers.UnsafeGetAssociatedSection(ContextInformation evalContext, String sectionPath) +116 System.ServiceModel.Configuration.ServiceHostingEnvironmentSection.UnsafeGetSection() +33 System.ServiceModel.HostingManager.LoadConfigParameters() +30 System.ServiceModel.HostingManager..ctor() +112 System.ServiceModel.ServiceHostingEnvironment.EnsureInitialized() +160 System.ServiceModel.ServiceHostingEnvironment.OnEnsureInitialized(Object state) +5
System.ServiceModel.PartialTrustHelpers.PartialTrustInvoke(ContextCallback callback, Object state) +84
System.ServiceModel.Activation.HttpModule.ProcessRequest(Object sender, EventArgs e) +103
System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +157 System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +65

Version Information: Microsoft .NET Framework Version:2.0.50727.1873; ASP.NET Version:2.0.50727.1433

share|improve this question

migrated from stackoverflow.com May 11 '11 at 6:34

This question came from our site for professional and enthusiast programmers.

    
@user Someone on Google got it to work by re-installing IIS. But you should take a hint from the close votes. :) –  bzlm May 10 '11 at 17:43
    
Serverfault will be a better place for this. You will also want to post more details about your situation. –  George W Bush May 10 '11 at 17:51

1 Answer 1

Probably need some more information to try and resolve this any further, but I would suggest you need to run the ASP.NET IIS Registration Tool (Aspnet_regiis.exe) after installing asp.net

share|improve this answer
    
I had already tried aspnet_regiis -i, but it didnt help... –  Anonymous May 9 '11 at 12:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.