Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an issue with the Vim color schemes: The background color does not fill the whole screen. For example, in the "blue" color scheme the whole screen should turn blue. Instead, the blue background only extends to the end of each line. Is this a setting in the console I'm missing or is this an issue with my vim default settings?

I'm only having this issue with Ubuntu 10.10. echo $TERM outputs xterm-color.

[Update]: To eliminate error sources my minimal ~/.vimrc looks like this:

filetype plugin on
colorscheme blue
syntax on

/etc/vim/vimrc contains the unchanged defaults of Ubuntu

share|improve this question
    
are you using screen? –  Uku Loskit May 11 '11 at 13:53
    
No, I'm not using screen –  chiborg May 11 '11 at 13:59
    
have you tried setting in vim set t_Co=256? –  Martin May 11 '11 at 15:08
    
can you post the relevant section of .vimrc? –  gerryk May 11 '11 at 15:44
    
set t_Co=256 makes the foreground text blink, but does not change the background color. –  chiborg May 11 '11 at 16:22

2 Answers 2

As explained here, disable Background Color Erase (BCE) by clearing the t_ut terminal option (run :set t_ut= in Vim and then press Control+L to refresh the terminal's display) so that Vim extends the color scheme's background color to the whole terminal screen. This also works if Vim is being used inside tmux or GNU screen.

share|improve this answer

I had the same issue with Ubuntu 12.04 and OpenBSD 5.1 when using vim inside of tmux. Ultimately, I was able to resolve it by setting my terminal type to screen-256color.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.