Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I read on MSDN that you can configure the Windows Process Activation Service (WAS) to automatically start an application pool when the application pool is created or when IIS is started. This only works on IIS 7.0 as far as I can tell. My question is how do I do this for IIS 6.0 (Windows Server 2003). I have a .net 3.5 app that takes 30 seconds to start for the first visitor.

The app is precompiled, so I don't think that is what is causing the delay. After the first person has had to wait for 30 seconds, everything works quickly.

share|improve this question
    
Isn't an application pool configured to restart when IIS is restarted? –  Michael Kniskern Jun 16 '09 at 22:32

3 Answers 3

up vote 2 down vote accepted

Here is a little utility I've used for "warming up" SharePoint sites in the past. I don't see why it wouldn't work for a non-SharePoint website.

share|improve this answer
    
+1 That's nifty :) –  squillman Jun 16 '09 at 21:40
    
That works great, thank you! –  Espo Jun 17 '09 at 7:14

A scheduled task to hit the url every now and then?

share|improve this answer

Have you tried looking at the Recycling options for the application pool? You can recycle it based on many different opitons.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.