Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Ok here's the deal. In trying to install SLES 11, partd says it cannot read the partitioning on my SAS disk. Specifically I can reuse the existing AIX partition table but not edit it. The drive is SAS and the arch is PPC, specifically a Power770. The drive used to be part of a rootvg and thus has AIX partition tables. I think I need to wipe the parition table off the SAS drive in order to make SLES happy. I've tried using Ubuntu PPC, YellowDog, and SLES but every shell I attempt to drop to is only ash and therefore does not have the correct drivers/commands.

I've also attempted to use the AIX 6.1 cd to erase the drive, but it takes forever and I end up just rebooting the LPAR. I'm also suspicious it leaves the partition table intact or leaves it for last...

I'm a bit of a AIX newb so please be nice :)

share|improve this question

2 Answers 2

up vote 1 down vote accepted

parted's mklabel command creates a new partition table, you'll need to decide what partition table format you want to use (msdos, probably. Possibly gpt if you have a sufficiently modern BIOS or your system uses EFI).

share|improve this answer
    
That helps, but my original question is how do I get to a point where I can boot the 770 and run dd or partd? ie, what variant/bootcd? –  JeremiahJohnson May 11 '11 at 20:47
    
Now I'm confused, weren't you able to run parted with the SLES 11 install? It should let you mklabel a drive it can't read the partition table on. Or is the problem that the SLES install can't access the drive at all (missing the driver?) –  DerfK May 11 '11 at 21:06
    
I'm not sure how to drop to a shell in the SLES install? I've never installed SLES but during the install it runs partd [automagically] and then says I can't edit the existing tables. It can see the drive just fine. Is there another way to issue commands inside the install? –  JeremiahJohnson May 11 '11 at 21:28
    
Most distributions set up a shell on an alternate console that you can activate. If you're using a graphical installer, you'll probably need to push something like Ctrl+Alt+F2 to get to that alternate console (and then push other combinations to figure out what console # the installer was running on to switch back, probably F5 F6 or F7). If it's a text console then just Alt+F2 should be enough (and the installer is almost certainly on console F1) –  DerfK May 11 '11 at 23:13
    
I didn't realize that. I still can't switch shells during the SLES install, not sure if it's a limitation of yast2 or what the deal is. I've tried launching a vterm from the HMC web interface and also directly via vtmenu. I've tried right-CTRL-ALT-Fn and left, no effect. Switching to a RHEL install to see if I can get another vterm. –  JeremiahJohnson May 12 '11 at 18:19

Have you tried wiping the entire drive with something like dban?

share|improve this answer
    
Ah did not realize that there was a ppc version. I'll try that. –  JeremiahJohnson May 11 '11 at 20:34
    
DBAN won't boot unfortunately –  JeremiahJohnson May 11 '11 at 20:49
    
Do you have i386 architecture that you can just plug the SAS drive into to wipe it? –  j.rightly May 11 '11 at 20:51
    
I don't unfortunately, this was my first inclination due to the specialized hardware I'm running. –  JeremiahJohnson May 11 '11 at 21:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.