Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

On a fresh clean install (that I did from CDROM) i keep getting the following errors (dmesg):

ATAPI device hdb:
  Error: Illegal request -- (Sense key=0x05)
  Parameter not supported -- (asc=0x26, ascq=0x01)
  The failed "Start/Stop Unit" packet command was: 
  "1b 00 00 00 03 00 00 00 00 00 00 00 00 00 00 00 "

ATAPI device hdb:
  Error: Illegal request -- (Sense key=0x05)
  Parameter not supported -- (asc=0x26, ascq=0x01)
  The failed "Start/Stop Unit" packet command was: 
  "1b 00 00 00 03 00 00 00 00 00 00 00 00 00 00 00 "

The drive is fine since i did the install without any problems.

Is there a way to de-activate this sensing/probing thing ?

fstab

/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
share|improve this question

1 Answer 1

up vote 1 down vote accepted

I believe your drive is going bad. Those errors are generally seen as warnings along the lines of "Hey, I'm still running for now, but be aware - I'm dying soon". I recommend installing smartmontools (http://sourceforge.net/apps/trac/smartmontools/wiki - probably available in your distribution) and look for climbing error rates.

The only other time I've seen those errors is when the drive parks itself, and Linux tries to access it without waking it up first. If this is a desktop, try using hdparm to disable power management on the drive:

hdparm -B 255

You don't want to do that on a laptop, as you wouldn't be able to properly "sleep" after that.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.