Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just upgraded our server to Ubuntu 10.04 and cron just stopped working. I tried to restart the server, restart cron but nothing worked for me. It just reports in /var/log/syslog:

May 12 16:32:01 uhor CRON[8424]: Module is unknown
May 12 16:33:01 uhor CRON[8430]: Module is unknown
May 12 16:33:01 uhor CRON[8429]: Module is unknown
May 12 16:34:01 uhor CRON[8432]: Module is unknown

Do you have any idea what's wrong? Some people were reporting also Module is unknown error after upgrading but it was usually with passwd command, not with cron.

Thanks :)

Edit: this is my /etc/pam.d/cron

# The PAM configuration file for the cron daemon

@include common-auth

# Read environment variables from pam_env's default files, /etc/environment
# and /etc/security/pam_env.conf.
session       required

# In addition, read system locale information
session       required envfile=/etc/default/locale

@include common-account
@include common-session-noninteractive
# Sets up user limits, please define limits for cron tasks
# through /etc/security/limits.conf
# session    required
share|improve this question

Read this bug report:

The solution is to restart cron: /etc/init.d/cron restart

At least it worked on my servers.

share|improve this answer
Indeed, but that bug is newer than @Martin's issue! ;-) – Henk May 31 '11 at 11:57
I ran upgrade today but it didn't help. Still Module is unknown ... – Martin Jun 16 '11 at 12:12

This is PAM related. Try:

aptitude reinstall libpam-modules libpam0g cron
share|improve this answer
Thanks for your advice but it didn't help. Still reporting just: May 12 17:01:01 uhor CRON[9342]: Module is unknown – Martin May 12 '11 at 15:02
Anything weird in "/etc/pam.d/cron", does that file exist or do the modules mentioned in that file exist on the system in "/lib/security/"? – Henk May 12 '11 at 15:14
Here's another one to try: "sudo pam-auth-update --force" – Henk May 12 '11 at 15:21
Maybe that's it. My "/lib/security/" contains only 10 *.so files and "" or "" are not among them. I have no idea where did they go. – Martin May 12 '11 at 16:48
Well... that explains the message "Module is unknown"! The is nowhere to be found on your system, not even with "locate"? On Ubuntu it's installed with package "libpam-modules", but that's what I suggested in my answer... – Henk May 12 '11 at 21:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.