Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got PHP 5.3.3 and nginx 0.8.47 compiled from source running a Wordpress blog. The RSS feed generated by Wordpress was getting truncated at roughly 16k (including header was 16k+90b). By adding the following to my nginx config:

fastcgi_buffers 8 16k;
fastcgi_buffer_size 32k;

the problem went away.. However, from what I read on the Nginx wiki page the buffers only determine when buffering will overflow onto disk. There is nothing that indicates the response can be truncated due to the buffers being too small..

So my question is, why was the response being truncated before changing this setting? It seems the request should not have been truncated, just a little slower due to disk buffering.

Additional info:

  • Ubuntu 10.04.2 32bit
  • PAGESIZE 4k
share|improve this question
2  
Are you sure that your fastcgi_temp_path is writable by the nginx process ? –  Ochoto Aug 2 '11 at 21:54

2 Answers 2

up vote 1 down vote accepted

At first try to see error_log (at level info, if nothing relevant printed at info level, try to read debug log).

share|improve this answer

Copy this text in your conf file of nginx

http {

        .....
        fastcgi_buffers 256 4k;
        .....
}

After restart nginx

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.