Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a hosting company that has setup a new server for me, but I noticed it was running RedHat 4.4 which I am worried about being such an old version. When I inquired about running an old version, they were reluctant to upgrade the OS.

I am wondering if I am being paranoid about running an old version of RedHat or if i am correct in asking for RedHat 6 to be installed to address improvements, security + bugs issues etc.

Edit: To avoid any confusion, here is the full version:

cat /etc/redhat-release

Red Hat Enterprise Linux ES release 4 (Nahant Update 4)

share|improve this question
add comment

5 Answers

up vote 11 down vote accepted

No, I wouldn't run RHEL 4.4 on a new server unless you have a specific need for RHEL4, in which case I'd run RHEL4.9.

  • There are remotely-exploitable vulnerabilities in RHEL4.4
  • You will have dependency problems if you want to install any modern software on RHEL4.

I'd go for RHEL6. It isn't that new.

share|improve this answer
    
i don't think he refers to RHEL, i think he actually refers to 4.4 pre-RHEL distro split version... like 1995-old –  lurscher May 12 '11 at 20:42
2  
Red Hat Enterprise Linux ES release 4 (Nahant Update 4) –  dyasny May 12 '11 at 21:24
add comment

According to RedHat's Lifecycle Document RHEL 4.4 (and I'm assuming RHEL, and not RedHat as Plain Redhat is DECADES old and out of support now) just left Phase 2, and will receive security updates and bug fixes till Feb 2012. However if I was installing a new server I would push for 5.x.

HOWEVER, at a minimum get them to get to the latests SP.

Given a choice, i would find a different provider. I can understand them not being ready to roll out 6, but 5 really is a must at this point. It just shows that they don't seem to have any interest in keeping current.

share|improve this answer
add comment

RedHat 6 is still fairly new, so i can somewhat understand them not jumping to it yet, HOWEVER, i dont really see a reason they're not on redhat 5.

share|improve this answer
add comment

Security updates and bug fixes are backported to older major versions, so I'd look at updating to 4.9 for now if possible (after sufficient testing, of course).

share|improve this answer
add comment

No, I wouldn't run RHEL4 on a new server as it would become EOL fairly shortly. I would put RHEL5 at the very least, though RHEL6 would be a better choice to give a longer life cycle. By going with RHEL4 there is the situation that you'll either need to perform an upgrade to RHEL5 or newer soon or run without any security patching as soon as RedHat EOLs that version. Also as mentioned RHEL4 is quite old by this point so you're liable to run into issue of needing newer versions of software that would be available in a newer release.

share|improve this answer
    
You'd be really hard-pressed to find a commercial hosting company (besides a mom-and-pop) that will actually support RHEL 6 right now, though. –  jgoldschrafe May 13 '11 at 2:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.