Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have one Exchange 2010 server which is fully updated, the clients are running Outlook 2010 but some users are getting a prompt for credentials every time they open Outlook.

I have checked for common errors like the checked box Always request authentication.

I think this happens only with new users that are created in AD and in Exchange and I can't do gpupdate - could that be related?

share|improve this question

migrated from stackoverflow.com May 13 '11 at 12:13

This question came from our site for professional and enthusiast programmers.

add comment

8 Answers

I've had this issue before on a client site, it may be entirely unrelated but I'll post my experiences here.

My first port of call to diagnose it was to open up outlook, leave the credentials request window open and then see where the request for credentials was going to; outlook has a handy tool built in that shows you all the connections it's making. To view it locate the notification area outlook icon in the taskbar (the icons on the right of the screen by the clock, rather than the ones to the left by the start menu) and then ctrl+right-click to bring up a slightly different context menu, in there click Connection Status.

When I did this I found that outlook was trying to make a connection to an public folders on an old exchange server that had been decommisioned and that this was happening because the current public folder was redirecting to the old one. I deleted the public folder and recreated it and voila, no more login prompts.

Of course there are a hundred reasons your outlook clients could be asking for credentials but I do recommend checking the connection status to see where it's pointing to, I found that once I entered the credentials the connection dissapeared in connection status, so that's worth trying.

share|improve this answer
add comment

Check control panel- user accounts and select manage your credentials, and look for the Outlook related information. Edit the information to reflect your current password.

share|improve this answer
    
hi, thanks for the reply, but is not that. credentials is empty. –  Jorge Machado May 13 '11 at 13:24
add comment

They need to change their user password. Once they do that, logout and log back in. That should fix the problem.

share|improve this answer
    
I have changed the password and reboot the client machine, still the same. any ideias ? I have no more ideias. May be the way that the new computeres are added to the domain ? –  Jorge Machado May 13 '11 at 16:58
    
Try uninstalling and reinstalling Outlook. –  Holocryptic May 13 '11 at 17:06
    
Already have done that too. I Think that could be a problem with the authentication from the computer to the AD . Have anyone experience something like this ? Another sinthom is that if i put my exchange account NOT in chached mode it does not ask me the password everytime that i startup the outlook. But that is not the solution... –  Jorge Machado May 13 '11 at 22:19
    
You say it only happens with new users you've created. Have you confirmed this? –  Holocryptic May 13 '11 at 22:23
    
Yes, it only Happers in the new users / new installed machinnes... Have anyone have this sythoms ? ´ –  Jorge Machado May 16 '11 at 20:26
add comment

I would also check to see if the users who are getting prompted are set to use Outlook Anywhere (RPC) and have "On fast networks, connect using HTTP first, then connect using TCP/IP" checked. This would cause them to be prompted for their password when opening their profile. This setting is found at:

File> Account Settings> Data Files tab> Settings > Connection Tab > Exchange Proxy Settings

share|improve this answer
    
That settings I have checked to the are correct, as they are as another computer that works fine. –  Jorge Machado May 13 '11 at 16:59
add comment

Is this issue definitely related to accounts and not PCs? ie, if you set up one of the new accounts on another PC with their Outlook/Exchange working fine, do you still get the problem? Also, windows logs on the effected computers aren't showing anything relevant?

I've seen this happen before, but it was caused by intermittent DNS issues on a badly set up network; the network was re-wired and reconfigured and it solved the problem, so I couldn't give you the exact change that solved it unfortunately!

share|improve this answer
    
so, this morning I have made some new tests, and I have test my outlook account on one computer that the user says that his outlook does not request credencials, and for my account it request it. So i think this is a config option on the server. Wee have recenty installed updates on Exchange server. Our network is fine and good configured to. The DNS issue i think it is not, but sometimes i can´t do gpupdate. Is this relevant ? –  Jorge Machado May 16 '11 at 13:22
add comment

This is a common complaint.

I could regurgitate this set of posts, but here is a link that helped me solve this in the past: http://social.technet.microsoft.com/Forums/en/office2010/thread/cd38f3f2-892f-470c-b52e-17b8beeb275e

If one of these steps works for you, please post what solved it.

I also found these: http://blog.montopolis.com/2010/10/24/outlook-2010-does-not-save-password-with-exchange/ http://www.msoutlook.info/question/481

share|improve this answer
    
Hi, Thanks for the reply, but none of this worked for me. I already have go throught that links... It is supposed that outlook when you are inside your company does not ask you any password because he can autenticate automatically –  Jorge Machado May 24 '11 at 9:06
    
Yes, Outlook does require a password every time, but in most cases, it gets it from pass-through authentication from when you log in. If you have Microsoft's hosted Exchange, they have a single-sign-on application that has a similar function. –  KCotreau May 25 '11 at 16:34
add comment

I Had this issue and applied the Office 2010 SP1 - it is a known error with Office 32bit on a 64Bit version of windows 7

share|improve this answer
    
Could you please add some references that agrees with you on that? –  Frederik Nielsen Nov 14 '12 at 21:57
add comment

Couple of thinks to check:

  1. Check to see if the time on both the clients and server is synced. If they are out of sync then Kerberos stops working, See the following TechNet article for more details: http://technet.microsoft.com/en-us/library/cc779260(v=ws.10).aspx

  2. Also on the clients check the following file C:\Windows\security\database\secedit.sdb. If the "Date modified" hasn't changed in a while then this fault might be caused by a corrupt Group Policy Security Database. Delete secedit.sdb on the effected clients and then run grpupdate /force from a Command Prompt or reboot the client.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.