Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having a quite strange issue. I'm mounting a NFS share from a SAN (ubuntu) to another machine (centos)

Mounting the share works just fine; but when I try some tests like :

dd if=/dev/zero of=bigfile bs=1k count=2000
2000+0 records in
2000+0 records out
2048000 bytes (2.0 MB) copied, 16.7555 seconds, 122 kB/s

On clientside, network has MTU 9000; i can successfully ping -s 8000 at least the server.

On SAN side it has 4 Gigabit interfaces bonded.

Both sides run NFS4; mounting using :

mount -t nfs4 192.168.3.3:/share /myshare/

Where should I start investigating ?

And what is the average transfer rate I could accept ? 50 Mb/s for a single gigabit connection ?

edit: server exports :

/export/share *(rw,insecure,async,no_subtree_check) 

edit: local storage test

time dd if=/dev/zero of=bigfile2 bs=1k count=200000
200000+0 records in
200000+0 records out
204800000 bytes (205 MB) copied, 0.509998 seconds, 402 MB/s

real    0m0.558s
user    0m0.009s
sys 0m0.546s
share|improve this question
    
What if you repeat the test locally on the server? This way you can verify if it is NFS issue. What if you try larger file? What if you rsync/scp over SSH and test? What are your server export and client mount options? –  grs May 13 '11 at 13:57
    
edited question with local test. I'll tryp scp and report. –  Disco May 13 '11 at 14:04
    
ok scp gives an average of 52 mb/s; but it's with the encryption overhead i think, no ? should it be faster ? –  Disco May 13 '11 at 14:06
    
Could you please show the client mount options? –  grs May 13 '11 at 14:37

1 Answer 1

You could try using different mount options than the default. Might be worth trying the following using the mount -o option and reruning your dd test.

rw,bg,hard,nointr,rsize=32768, wsize=32768,tcp,timeo=600, actime=0

Try reading man nfs for details on the mount options and what they mean.

share|improve this answer
    
mount -t nfs4 -o rw,bg,hard,nointr,rsize=32768, wsize=32768,tcp,timeo=600,actime=0 doesn't seem to work. –  Disco May 13 '11 at 14:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.