Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a windows 200864r2 domain controller with shares that work great from win7 clients.

I have a new ubuntu natty 64 install with an entry like this in /etc/fstab:

//svr/music /mnt/music smbfs credentials=/home
/john/.smbcredentials,iocharset=utf8,uid=1000,gid=1000,file_mode=0771,dir_mode=0771 0 0

in that .smbcredentials file I have:

username=john
password=afairlysimplepassword - no special characters, or even numbers
domain=domainname

that file has these permissions:

-rw-------  1 root root     44 2011-05-13 12:11 .smbcredentials

**my mnt dir is:

drwxr-xr-x 23 root root 4096 2011-04-29 07:05 ..
d?????????  ? ?    ?       ?                ? music

so something is off kilter there, but I've never seen ???? like that (but I'm not TOTALLY new to linux)**

this linux workstation configuration is cobbled from various googling to figure out how to do this the 'right way'.

in windows parlance, \\svr is my domain controller, and it is dns/dhcp and so on

MY PROBLEM:

When I first log on to the ubuntu workstation, I can see the /mnt/music directory and it has my music from \\svr\music in it and the proper permissions seem to be applied. Then after a while (TM), I can't get to it any more and the /mnt/music directory, seems to turn into a file that can't execute. Doing sudo mount -a will then start giving cifs 13 errors. Sometimes it will come back and sometimes a reboot doesn't necessarily fix it. During all this other windows clients are having no problems. Server restarts don't appear to effect it either.

I realize something is up with my mnt dir perms, but I also get the idea that I'm doing something old and not recommended anymore based on recommended man pages, so I don't want to just shoot some chmods at it.

what keywords do I type into google to find simple single sign on but in linux, so I can just have simple 'log into any station and have your network drives and printers all connected with proper permissions centrally managed without any MS Windows at all'? free would be nice but not totally necessary.

Any guidance appreciated.

share|improve this question

1 Answer 1

I have found a solution on Windows 2008 Server. I deactivated SMB Signatures by setting the HKLM\System\CurrentControlSet\Services\LanManServer\Parameters\RequireSecuritySignature registry key to 0. I rebooted and my problem was solved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.