Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a fresh install of IIS 7, and under the Handler Mappings, I see a section for Disabled mappings and a section for Enabled. I want to disable a bunch of extensions (cshtml, aspq, etc). That is, I want to "move" them from the Enabled section to the Disabled section without deleting them. How do I do this?

(EDIT: Oops. It's IIS 7, not 7.5.)

share|improve this question

3 Answers 3

up vote 1 down vote accepted

You can not disable individual handler mappings in the UI. The 'Edit Feature Permissions' mentioned by Mark Henderson applies to the whole feature 'Handler Mappings', so it applies to all mappings, not a single one.

There are really three groups of handlers, one that requires Execute permission such as, 'ISAPI-dll' or 'CGI-exe', the second group that requires 'Script' permissions, all the handlers are in that group. The third group of handlers only requires 'Read' permission, 'StaticFile' is an example of this. Because it does not execute a process nor does it run a script, it just reads a file from the file system.

You can check this by open 'Edit Feature Permissions' and uncheck 'Script', most of the mappings are now disabled. Uncheck 'Read' and the last few enabled ones are disabled as well.

To remove a handler from a site, open the web.config and add something like this:

      <remove name="PageHandlerFactory-Integrated-4.0"/>

This will remove the integrate ASP.NET 4 page handler, which means web forms (aspx) will no longer work.

If you look at the 'Handler Mappings' for the same site in IIS Manager, that mapping still shows up in the enabled section, even though it does no longer work for the site.

share|improve this answer

just uncheck the execute checkbox, that moves it to disabled section in our case, solved the connect computer wizard not working on SBS 2011.

share|improve this answer

My problem wasn't any of the other answers listed here. At some point the "StaticFile" handler mapping had been disabled. In order to re-enable this:

  • Go to the top level of the server you're managing
  • Go to Handler Mappings
  • Click StaticFile and then click Edit Feature Permissions... in the right panel.
  • Make sure the Read checkbox is checked.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.