Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

By default syslog daemons don't accept remote log submissions. I need mine to, but don't really have a clue how to configure that. Can anyone help me out, send me a good tutorial, etc. I have been googling for awhile, but can seem to find what I'm looking for. Any help would be appreciated

share|improve this question

migrated from stackoverflow.com May 15 '11 at 20:36

This question came from our site for professional and enthusiast programmers.

2 Answers 2

Read the man-page for your operating system (man syslogd). On FreeBSD, you need to pass -a and the addresses of white-listed senders to the syslogd invocation.

share|improve this answer

man syslogd
-r This option will enable the facility to receive message from the network using an internet domain socket with the syslog service (see services(5)). The default is to not receive any messages from the network.

on centos, should be like this $ cat /etc/sysconfig/syslog |grep OPT SYSLOGD_OPTIONS="-m 0 -r"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.