Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have simple problem on few laptops with Windows 7 64-bit. They uses wi-fi network and all works fine, but sometimes, after hibernating and restoring system, wi-fi network is disabled (Wi-Fi icon in notifying area is marked with red cross). To enable it, users have to open Windows Mobility Center and click "Turn on wireless connections" (name can be little different, as I use polish version of os and this is my translations of this button caption). After doing that all works fine but this is little problem for my users as:

  1. Some users are so inexperienced in using computers, that this task is sometimes too complicated for them :-)
  2. Necessity of constantly doing the same thing becomes little annoying.

I could not determine what conditions must be fulfilled for this situations to occur (if it happens, it always happens after hibernation, but not every hibernation causes this).

I suspect some settings responsible for energy saving (I have already disabled "Allow computer to turn off this device to save energy" setting for wifi adapter, but I don't know whether it will be enough. Sometimes, problem didn't occur for few days and one of the users who is most annoyed by this little problem is my boss :-) )

Have you any suggestions how to stop Windows from doing this?

share|improve this question

3 Answers 3

up vote 0 down vote accepted

I would register a scheduled task with the Task Scheduler, that triggers on logon or workstation unlock. Unfortunately, Windows doesn't provide a trigger for "resume from hibernate", but assuming that your Win7 installations are configured to require an unlock after a resume, this should allow you trigger a script.

Then, use the [devcon utility] (http://support.microsoft.com/kb/311272) to enable the wireless device. I have never used it personally, but a lot of people seem to have success with it. For some instructions, see this link:

http://wlanbook.com/enable-disable-wireless-card-command-line/

Alternatively, you can also have the task trigger on a event from the event log, if the wireless card or the OS logs something when the device is offline.

Devcon has a few options that you can apply to devices, and "restart" or "enable" should do the trick.

share|improve this answer
    
Thank you for your suggestions, but Windows disables "wireless network" and not "network adapter" - I have already checked in device manager, that when wifi network is disabled, wireless network adapter remains enabled. –  user71061 May 16 '11 at 15:25
    
You should look into the "netsh" command. If the adapter is enabled in device manager, but disabled under the "network connections" control panel view, then you should be able to enable it using with the command like this netsh interface set interface "Wireless Network Connection" ENABLED. Verify the name of the connection with netsh interface show interface, and make sure you run the command as an administrator. –  Lucky Luke May 16 '11 at 16:42
    
Ok, I will try it. –  user71061 May 17 '11 at 13:47

Every laptop I have ever seen have a phisycal way to activate/deactivate the wifi card from the keyboard, if not from a swich on a side. Look for a key marked "Fn", usually in blue or (faded) grey and then one of the F keys with an icon picturing an antenna. That combination of keys acts on the hardware. They will do the trick I hope.

tengonick

share|improve this answer

This could be due to switching off the Wi-Fi adapter by the Power Options.

Check this> open network sharing center> manager wireless networks> adapter properties> configure>power management> unclick "allow the computer to turn off this device to save power"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.