Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a mail server which received emails from our company PDAs and dumps them to a drop box (anything to another domain is reject) which has been working for a number of years.

However we are now getting more and more phones which are unable to send emails to this drop box - looking at the logs it appears that T-Mobile now give each phone it's own IP address and hostname (previously there was a pool of about 5 which were used) - for example whenever the phone fails to send a message like the following appears in the log

May 16 13:49:37 photo postfix/smtpd[30868]: warning: 178.97.139.65: hostname customer35650.97.ld.cust.t-mobile.co.uk verification failed: Host not found

Looking at all the failures it appears that T-Mobile haven't set up reverse DNS entries as nslookup says

** server can't find customer44546.104.wv.cust.t-mobile.co.uk: NXDOMAIN

Connecting to WiFi at home or work (no VPN off site) and attempting to send shows that the sending from the device works.

Is it possible to disable the name checks in Postfix?

share|improve this question
    
    
Did you look at any of the answered questions which you were prompted with when you posted this? Did you try Google? –  symcbean May 16 '11 at 13:43
    
Of course I tried Google - that failed miserably. As with your first link most people seam to want to disable the message rather than the actual cause! –  Kev Jun 21 '11 at 8:42
add comment

1 Answer

If you want to disable this behaviour, look for the smtpd_client_restrictions setting in main.cf and remove reject_unknown_client_hostname or reject_unknown_reverse_client_hostname.

share|improve this answer
    
Those options aren't active on the server, if you issue "postconf | grep client" the following results are shown:- smtpd_client_restrictions = unknown_client_reject_code = 450 –  Kev Jun 21 '11 at 8:41
    
please issue "postconf -n | grep client_hostname" and remove that from the occurrence. –  mailq Jun 24 '11 at 21:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.