Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Having a bit of a problem with my hosting company rackspace cloud and SFP records. I asked them to updated it on there DNS. This is what they set it as:

seonky.com. 300 IN TXT "v=spf1 ip4:ubuntu a include:184.106.171.113 ?all"

However when I test it with gmail I get this:

Received-SPF: unknown (google.com: domain of noreplay@seonky.com uses a mechanism not recognized by this client. unknown mechanisms: )) client-ip=184.106.171.113; Authentication-Results: mx.google.com; spf=permerror (google.com: domain of noreplay@seonky.com uses a mechanism not recognized by this client. unknown mechanisms: )) smtp.mail=noreplay@seonky.com Received: from MFP2 (localhost [127.0.0.1])

Any idea what I should tell them so that they will fixe it and not ask me to go generate another SFP?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

You're looking to tell Google that they need to change their SPF checking client to work with your record?

I don't want to sound harsh here, but the blame is not with them, and you do need a new SPF record.

The ip4 setting needs to be an IP address, and the include record needs to be a domain name. Not sure what you're intending with your record, but something like this may be what you want:

v=spf1 a ip4:184.106.171.113 ~all

See the documentation here for more info on what can go into these records.

share|improve this answer
    
I don't want Google to change, that would be silly. Just trying to sort out why it's not working. I'll give "v=spf1 a ip4:184.106.171.113 ~all" a try, then I'll go for "v=spf1 ip4:184.106.171.113 a include:seonky.com ?all" (correct??) if the mail keeps going into the spam box. –  Levi May 16 '11 at 18:56
    
You wouldn't want to include the domain that the record's in. That would create an infinite loop - which I'm sure most checkers will account for, but may invalidate your record in some cases. –  Shane Madden May 16 '11 at 18:58
    
Status is showing as passed so I'm guessing it worked. Thanks - Received-SPF: pass (google.com: domain of noreplay@seonky.com designates 184.106.171.113 as permitted sender) client-ip=184.106.171.113; Authentication-Results: mx.google.com; spf=pass (google.com: domain of noreplay@seonky.com designates 184.106.171.113 as permitted sender) smtp.mail=noreplay@seonky.com –  Levi May 16 '11 at 21:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.