Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm doing some Rails dev, and I'm trying to get Pow running. After making the appropriate symlink, if I try to go to (idealm_web being the name of my Rails project), I get this:

It's gorgeous, but useless right now.

I was told that this was Apache. How do I disable this? I checked under System Preferences > Sharing, and there was no way to disable it.

[Cross-posted from AskDifferent, here. Are we allowed to do this?]

EDIT: Here is a screengrab of System Preferences > Sharing. I don't see Web Sharing anywhere, and this is where OSX pointed me when I typed in 'web sharing' in Spotlight.

enter image description here

share|improve this question
Turn off Web Sharing. You might have to restart. There are other ways of doing it also. Keep searching. – Kent May 16 '11 at 20:59
What are some of these other ways? I have been searching already - that's why I posted here. Please see my edit of the question. – kivetros May 16 '11 at 21:13
No, please do not crosspost. Apple.SE is for end users, this is a server question and belongs on ServerFault. – Sven May 16 '11 at 21:26
up vote 4 down vote accepted

This is different with the Server version of OS X: You need to start the Server Admin application (likely under /Applications/Server) and deactivate the Web service there. Alternatively, use the terminal and issue the command sudo serveradmin stop web.

share|improve this answer
Worked perfectly - thanks. :D – kivetros May 17 '11 at 13:28

This may be because the default virtual host in Mac OS X Server's Apache configuration answers to *. You can turn off Apache as other answers have suggested, or you can use the Server Admin utility, edit the Web Service settings, and take out that wildcard to see if that helps.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.