Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have Win 2008 running on a Ubuntu 10.04 host using KVM/QEMU. The version is 0.12.3. Event thought the Win 2008 is idle (no updates, most services are turned off), on the host server one of the core is pegged at 99%. Keeping the system average load above .60 most of the time.

I downloaded the latest version of qemu (0.14), thinking it may solve the issue. I have not upgraded yet. Since it needs to match up to the right kernel module. I just wanted to find out: How do I go about doing this upgrade? Kernel version is : 2.6.32-28-server

I started with the ./configure, but got a zlib check failed.

Thanks!

share|improve this question
    
Are there other Win 2008 guests on the host? –  HTTP500 May 16 '11 at 22:55
    
I got the source to compile, not sure how to switch the host to using the newer version. –  taazaa May 16 '11 at 22:57

2 Answers 2

up vote 1 down vote accepted

The configure Script check for dependency and verify that it's satisfied then generate a make file that you can use to compile and build the binary executable.

In this case give you zlib check failed because zlip ins't installed, install zlib and then try again .

Installing zlib on Debian is quite simple, just :

apt-get install zlib1g zlib1g-dev
share|improve this answer
    
Thanks I did that and got the source to compile. I am not sure how to make the system use the new version. I did a make install, but when i check the version using kvm -version. I still get 0.12.3 –  taazaa May 16 '11 at 22:54

I had a similar problem once; upgrading to Ubuntu 12.04 (with latest versions of both KVM and libvirt) solved the described behaviour.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.