Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm having some issues trying to make my Wordpress installation "bullet proof". I was installing Wordpress on my testing server, when I noticed that I had a permission problem with folders and themes installation. I tried to fix it using the following commands, located in this SF answer:

For Directories:

find [your path here] -type d -exec chmod 755 {} \;

For Files:

find [your path here] -type f -exec chmod 644 {} \;

You have to omit to use this command for /wp-includes/.

Now I just see a blank screen in my Wordpress directory. I don't want to chmod 777 the Wordpress directory. That would fix the problem, but would create a security issue.

share|improve this question
check your error log why you are white screening –  Mike May 17 '11 at 16:13
well I just change the permissions to 777 again hahaha and now I'm able to see my regular wordpress, now I'm wondering why in my Mac OSX I did not have problems like this one, I just intalled MAMP, downloaded the last wordpress package and that's it! is it any other setting in Apache or something that I have to check? –  mckain May 17 '11 at 16:21
I got it! Finally It's working! I just switch my user for root and then reInstalled wordpress, and that's it! I didn't have to chmod any file! pffff! I'm tired! need a beer! hahahaha –  mckain May 17 '11 at 16:41

2 Answers 2

Apache doesn't need to write to any of the web root in order to make wordpess function properly, all it needs to do is read

So, given that..the last octal in your UNIX permissions can be set to 0 always (so in reality, this would be 750/640)

Depending on ownership, you may need to run 770/660 inside of wp-content in order to allow the apache UID to write/move into that directory. This is an uncool solution, as it means apache gets pretty much full access on wp-content and ideally you want the files to be owner by someone other than apache...preferably a human being.

I've written up a blog post on wordpress file permissions which you might want to take a look at.

share|improve this answer

Depending on your setup it can happen that those settings are not permissive enough. You may need to grant write access (77*) to the group (HTTP server process) too, at least to selected files/directories.

See Changing File Permissions on for more information.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.