Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have mail working for continuumconcepts.com right now. My mx records point to my assigned google postini servers. Works great.

I have another server out in the wild that is completely disconnected from this network, and I have named it sfr.continuumconcepts.com. I'd like to get mail working on it as well, for test purposes (I'll be using it for other domains later).

I've added sfr.continuumconcepts.com as an mx record, but nslookup -type=mx sfr.continuumconcepts.com doesn't seem to show it yet. I don't know if I need to wait longer or if I set it up incorrectly.

Here's a screenshot of my DNS manager at godaddy. As far as I know, this is public information so hopefully I am not embarrassing myself by revealing too much. :)

In the MX record setup, this is the blurb godaddy gives: "MX records are for routing email that is addressed to a particular domain name. Like a CNAME record, an MX record points one domain name or subdomain to another domain name or subdomain for which an A record exists. Entering "@" for the host name is the same as entering your domain name, minus the "www." Entering "www" for the host name is the same as entering your domain name, including the "www"."

Does this look like it's set up properly? Thanks in advance.

share|improve this question
add comment

2 Answers

up vote 6 down vote accepted

Yes, you can have an MX record for a 3rd level domain. You can have a MX record for anything (not that it makes sense in all cases).

Looks like it was a propagation delay because I see it:

 $ host -t mx sfr.continuumconcepts.com
 sfr.continuumconcepts.com mail is handled by 10 sfr.continuumconcepts.com.

+1 for actually showing your domain and making troubleshooting so much easier.

share|improve this answer
    
Thank you for your prompt response! –  Chris May 17 '11 at 19:02
add comment

It is set up properly from a DNS perspective:

dmourati@cm:~$ dig -t mx sfr.continuumconcepts.com

; <<>> DiG 9.3.4-P1.2 <<>> -t mx sfr.continuumconcepts.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31579
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3

;; QUESTION SECTION:
;sfr.continuumconcepts.com.     IN      MX

;; ANSWER SECTION:
sfr.continuumconcepts.com. 900  IN      MX      10 sfr.continuumconcepts.com.

;; AUTHORITY SECTION:
continuumconcepts.com.  897     IN      NS      ns46.domaincontrol.com.
continuumconcepts.com.  897     IN      NS      ns45.domaincontrol.com.

;; ADDITIONAL SECTION:
sfr.continuumconcepts.com. 897  IN      A       184.168.71.236
ns45.domaincontrol.com. 718     IN      A       216.69.185.23
ns46.domaincontrol.com. 718     IN      A       208.109.255.23

You do not yet have an SMTP listener on that host though:

dmourati@cm:~$ telnet sfr.continuumconcepts.com. 25 Trying 184.168.71.236..

share|improve this answer
    
I didn't realize you actually got in first! Thanks for your quick response. There should be a mail server listening there now, by the way, although it's not yet set up. –  Chris May 17 '11 at 19:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.