Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to find out why I have intermittent disconnection on my network whenever another device like the common home router is plugged on to the network. I have litle power to discourage this because I do work with Hotel/ Hospitality industry. What can I do to detect and block this devices when connected or make my network stable even when these devices are on the network?

share|improve this question

Without more information such as the layout or a description of your network topology we can't really answer your question. I would suspect that you have a single broadcast domain, and therefore when I a rogue device that is running DHCP is plugged in that clients attach to it instead of your existing layer 3 design.

share|improve this answer
Normally I'm with you on your answers but I disagree with this one. A DHCP client in the bound state won't (or shouldn't) be affected by a rogue DHCP server coming on line. In addition, a DHCP client who's renewal timer expires will try to renew it's lease with the server that originally granted the lease. Only if it's unsuccessful in renewing it's lease will it attempt to communicate with any other DHCP server. This scenario is possible but highly improbable, in my opinion. – joeqwerty May 18 '11 at 1:30
You raise some good points. Based on the statement about home routers I surmised that rogue DHCP action is the most likely culprit here. Without any kind of topology we're shooting blanks. – SpacemanSpiff May 18 '11 at 6:09
I was thinking it may be related to flooding due to an STP topology change caused by connecting the router to one of the switch ports if the ports aren't configured for portfast. In addition, if the router supports and has STP enabled it may be inadvertently altering the STP topology. – joeqwerty May 18 '11 at 11:28

Have you enabled spanning tree protocol on your switches?

share|improve this answer
More to the point, has the OP enabled portfast on all ports not participating in the STP topology? – joeqwerty May 17 '11 at 23:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.