Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a reseller hosting plan on which I have my company web hosting account.

I have the email hosting pointing at a Google Apps Account and for the most part it works ... the problem comes with sites I have on the hosting account that send emails directly to the same email account from forms I have on the sites ... for some reason, those emails never get to the google apps account and are stored on the server.

I know because if I send emails from forms on the site, nothing comes to my inbox (configured to pull from google) but if I log in to cpanel and try go to view the email for the account, I see them there.

How can I fix this?

share|improve this question

2 Answers 2

What is your App using for it's outgoing mail server? Some hosting sites require you to use their mail server to send and some e-mail providers require that you be on their network or authenticate your account to send through them.

Depending on the way your app is sending the e-mail you may need to configure your outgoing mail server or authenticate to it.

share|improve this answer
    
Its not an app ... its just a php webform ... probably using sendmail or whatever is on the server –  trustfundbaby May 18 '11 at 7:26
up vote 0 down vote accepted

Turns out you just have to turn off local delivery on your server, this was the post that led me to it http://www.directadmin.com/forum/showthread.php?p=189477

If you use Cpanel/WHM then in WHM Main >> DNS Functions >> Edit MX Entry and pick "Remote Mail Exchanger"

Hope this helps someone.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.