Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've installed Ubuntu Enterprise Cloud on a server and I'm able to bring up an instance from a image and the instance shows that is running. I see the IPs allocated to that instance but for some reason I can't access it via SSH.

euca-describe-groups shows:

GROUP  admin default default group
PERMISSION admin default ALLOWS tcp 22 22 FROM CIDR 0.0.0.0/0

I'm on the same network as the instance so I'm sure is not an networking problem (like routers, switches etc.).

Any ides?

share|improve this question
add comment

2 Answers

A few things to check would be

  • Did the instance really start ? ssh to the NC, and try "virsh list", is it listed?
  • A minimum UEC installation requires two nodes, with the NC node having VT support in the CPU. Can you login to the NC node and try "kvm-ok" ? what does that say
  • Can you ssh into the instance from the CLC node ?
share|improve this answer
    
I have everything on the same machine. CLC, NC etc. I'll try your suggestions and I'll let you know the results. –  itgorilla May 19 '11 at 15:53
add comment

I just installed UEC on a single box where the node controller and the cluster controller on the same machine.

Make sure you create an SSH keypair in order to access the instance:

euca-add-keypair eucakey > ~/.ssh/eucakey

Then when you create an instance, create it with that key:

euca-run-instances -k eucakey emi-54E71716

Check to make sure that the instance is running:

euca-describe-instances

Finally, login to the instance:

ssh -i ~/.ssh/eucakey ubuntu@

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.