Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Running the command

sudo rsync -a -e ssh /home/blah user@server:/home/blah

rsync seems to be renaming directories (not sure if it is renaming files). For example, "M.I.A." is being converted to "MPTBTC~C". This also happens when copying over samba.

The target file system is ext4.

Update: This appears to only happen with directories that end with a period. A google search indicates this should only be a problem under windows, but I am syncing from linux (ext3) -> linux (ext4).

share|improve this question
    
What version of rsync do you have and what does it claim it is doing when you use -vn? Can you construct a new directory on the source system and a new target directory which reproduces the problem? If so, please provide a script to create the example setup and rsync it. –  Seth Robertson May 19 '11 at 21:16
    
Apparently, this is not strictly an rsync issue. Attempting to copy the directories over samba also results in the same problem. –  Abtin Forouzandeh May 26 '11 at 22:40
    
Also, this does not happen when doing the rsync or copy locally. –  Abtin Forouzandeh May 26 '11 at 22:44

1 Answer 1

Try using the --iconv parameter of rsync to rule out encoding issues. For example:

rsync -a -e ssh --iconv=utf8,iso88591 /home/blah user@server:/home/blah

This will force rsync to use UTF-8 for local filenames and ISO-8859-1 (Latin-1) for remote filenames, "translating" as needed.

You can also try using the convmv utility (apt-get install convmv on Debian-based systems) to fix local encoding issues, although the filename you posted doesn't look like the kind of name convmv generally fixes.

Also, please post links to the findings you mention.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.