Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

For automation purposes, I build a certain application which sends and receives UDP packets, and I run this tool every few hour on a Windows 7 machine. However the Windows firewall blocks me from sending/receiving packets - I get the message "Windows firewall has blocked some features of this program".

Because this tool gets rebuild, I can't add a rule saying "let this program use UDP". Instead, I wrote two custom inbound rules and two custom outbound rules. The rules open up UDP and TCP for both sending and receiving.

Despite this, my app keeps getting blocked.

However, if in the Windows Firewall Properties, I go to the Domain Profile tab and allow both Inbound and Outbound connections, my app is not blocked. Setting those to back "block (default)" and my app is blocked again.

The application itself is not on the local machine, it's executed from the network. Could that be why the firewall rules I set don't apply?

share|improve this question
    
have you looked into the firewall logs? –  tony roth May 20 '11 at 3:15

2 Answers 2

use a port based rule instead rather than an application rule

share|improve this answer
    
I cannot use an application rule because my application's name and location keeps changing. I am currently using 4 port based rules to allow any ports for UDP and TCB, inbound and outbound, to be used - but my app is still blocked. –  sys2197 May 19 '11 at 21:32
    
If I understasnd you you have created 2 custom rules for any program allowing tcp and udp for inbound and outbound for all IP addresses to allow traffic and it's still getting blocked? Are you sure you have the right ports? –  Jim B May 19 '11 at 22:50
    
I have 4 different rules. Rule 1: Allow Inbound TCP on any port. Rule 2: Allow Inbound UDP on any port. Rule 3: Allow Outbound TCP on any port. Rule 4: Allow Outbound UDP on any port. –  sys2197 May 19 '11 at 23:14
1  
those rules should effectively disable the firewall entirely, are you sure there is no other rules on the firewall? Are all communicaion TCP or UDP? I would try making a custom rule instead with all protocols and see what happens –  Jim B May 19 '11 at 23:19

As Jim B said, use a port based rule instead rather than an application rule,

Also check if there aren't other rules in you firewall settings that would superseed yours. This could be a application rule on deny that work on same port as your program.

You might also want to fire up Wireshark (http://www.wireshark.org/) to see what port are used to initialized the connection.

You can use http://packetlife.net/media/library/13/Wireshark_Display_Filters.pdf to be able to filter out packets you don't want.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.