Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Situation: I've got some machines with Dell iDRAC6 Enterprises that I need to kickstart remotely.

Usually, I'd go to the datacenter, jam the CD and floppy (with ks.cfg) in the machine, and be on my way. The last build I did, I "burnt" the ISO onto a flash drive with UNetBootin, jammed all the kickstarts on the root of the same flash drive, and was able to boot with "linux ks=hd:sdb1:/hostname-ks.cfg." Problem is, I'm doing everything remotely now.

I've loaded up the DRAC interface and mounted both the floppy with ks.cfg and RHEL netboot CD mounted. It boots off the CD, but when I do

linux ks=floppy

The kickstart can't be located and it proceeds into the regular non-automated installation.

I've also tried "linux ks=fd0:/ks.cfg," "linux ks=hd:fd0:/ks.cfg," and a few other permutations, to no avail.

I think if I could figure out what the device names for the virtual CD and floppy that the DRAC presents to the system are, I'd be in good shape.

share|improve this question
add comment

2 Answers 2

I had the same problem, though it was for installing an ESXi:

  • The Virtal Floppy is considered as generic USB storage (seen in /var/log/messages)
  • The USB device need to have a FAT16/FAT32 partition (seen in /usr/lib/vmware/weasel/usbmedia.py), but it looks specific.

Context:

  • iDRAC 6 v3.2
  • VMware-VMvisor-Installer-4.1.0.update1-348481.x86_64-Dell_Customized_A04.iso

Here are the rough steps:

$ dd if=/dev/zero of=ks.img bs=1000 count=32000 
$ fdisk ks.img

Create partition and note start*512 as offset (1048576 here) ; Change partition type to FAT16

$ losetup -o1048576 /dev/loop0 ks.img
$ mkdosfs /dev/loop0
$ mount /dev/loop0 /mnt/tmp
$ cp ks.cfg /mnt/tmp
$ umount /mnt/tmp
$ losetup -d /dev/loop0

Then add ks=usb on ESXi boot command line.

share|improve this answer
add comment

http://support.dell.com/support/edocs/software/smdrac3/idrac/idrac10mono/en/ug/html/racugc1b.htm

I cannot locate my Virtual Floppy/Virtual CD device on a system running Red Hat Enterprise Linux or the SUSE® Linux operating system. My Virtual Media is attached and I am connected to my remote floppy. What should I do?

Some Linux versions do not automount the Virtual Floppy Drive and the Virtual CD drive in a similar manner. To mount the Virtual Floppy Drive, locate the device node that Linux assigns to the Virtual Floppy Drive. Perform the following steps to correctly find and mount the Virtual Floppy Drive:

  1. Open a Linux command prompt and run the following command:
    grep "Virtual Floppy" /var/log/messages

  2. Locate the last entry to that message and note the time.

  3. At the Linux prompt, run the following command:
    grep "hh:mm:ss" /var/log/messages where: hh:mm:ss is the time stamp of the message returned by grep in step 1.

  4. In step 3, read the result of the grep command and locate the device name that is given to the Dell Virtual Floppy.

  5. Ensure that you are attached and connected to the Virtual Floppy Drive.
  6. At the Linux prompt, run the following command:
    mount /dev/sdx /mnt/floppy where: /dev/sdx is the device name found in step 4 /mnt/floppy is the mount point.

It sounds like you might need to install the OS the old fashioned way to begin with, find out the details, and then you should be OK for future installs.

share|improve this answer
    
On an identically configured system, nothing pops up in /var/log/messages regarding the virtual floppy. Only the virtual CDROM gets a mention. –  brian May 20 '11 at 5:24
    
@brian - can you just do trial-and-error going through /dev/sd[x] devices until you find the right one? –  Mark Henderson May 20 '11 at 5:30
    
I've tried iterating through all of them, and no dice. I had another idea with using the flash drive image that comes with RHEL instead of the boot CD. I copied all the machine.cfg kickstarts to the root of it, then mounted that under the virtual floppy. I was able to boot off of it, but when I specify "ks=floppy:/<machine>.cfg," it just continued through the regular (non-automated) install. –  brian May 20 '11 at 5:50
    
@Brian - is it like that on every iDrac 6 Enterprise you've got? –  Mark Henderson May 20 '11 at 5:52
    
Yup, even with DRAC5, no go. The virtual floppy simply isn't presented to the system the same way the virtual CDROM is. –  brian May 20 '11 at 14:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.