Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

INPUT:

dig +multiline google.com axfr

OUTPUT:

; <<>> DiG 9.7.3-RedHat-9.7.3-1.fc14 <<>> +multiline google.com axfr
;; global options: +cmd
; Transfer failed.

What am I missing?
Regarding: DNS Lookup to Bind config file.

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

You need to use dig against your own nameservers when you attempt a zone transfer. This needs to be specifically permitted by the allow-transfer directive. Zone transfers should be disabled by default to protect the zone from prying eyes and from the possibility of a denial of service attack.

share|improve this answer
add comment

Google is not going to let you do a zone transfer from them.

Zone transfer permissions are in most cases granted only to a very specific subset of other hosts, and almost never to the public at large.

share|improve this answer
1  
Will help explain why zone transfers are restricted sans.org/reading_room/whitepapers/dns/… –  Sameer May 20 '11 at 5:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.