Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using a Windows 2008 R2 Server (Workgroup) as file sharing server. Even though Everyone has full control (both Share permissions and NTFS permission) to the folder and Password protected sharing is on, I still get a login prompt when trying to access the share from another 2008 computer. From a Win7 client it works as expected with no prompt.

What could I have missed?

share|improve this question
1  
your answer is quit fine but first you should enable the Gust Account from the Local Security Policy then it will work – user202298 Dec 12 '13 at 10:27
    
Thank you Imtiaz, your suggestion pointed me to the final piece to get this working for a client. – Thor Erik Feb 27 '14 at 13:00
up vote 5 down vote accepted

Make sure the "ANONYMOUS" security object is granted access. "EVERYONE" doesn't count.

You also might need to allow anonymous access within group policy. Open Group Policy Editor and navigate:

- Computer Configuration
  - Windows Settings
    - Security Settings
      - Local Policies
        - Security Options.

Change “Network access: Let Everyone permissions apply to anonymous users” to Enabled

share|improve this answer
1  
Thanks for the suggestion. I granted access to ANONYMOUS LOGON and changed the Security Option in question. I also ran gpupdate for good measure, but I still have the same behaviour. – Zano May 20 '11 at 14:54
1  
After reading this answer I changed Network access: Sharing and security model for local account from “Classic-local users authenticate as themselves” to “Guest only-local users authenticate as Guest”. Now it works. – Zano May 20 '11 at 16:14
    
@Zano, your recommendation works for me! Thank you! – Sergey Nov 2 '12 at 8:40
    
@Zano, thanks. This was the missing piece for me. The security policy was reset (somehow); it was driving me up the wall. – Tim Richardson Jan 11 at 1:56

Boiled it down to this:

On the file server Give anonymouse Share and NTFS rights as needed (Read in my case)

Create GPO and apply to file server Computer - Windows - Security - Local - Security

Accounts:Guest account status - Enabled

Accounts: Rename administrator account - SomeNameOfYourChoise

Accounts: Rename Guest account - SomeNameOfYourChoise

Network access: Shares that can be accessed anonymously: YourShareName

Network access: Sharing and security model for local account from “Classic-local users authenticate as themselves” to “Guest only-local users authenticate as Guest”.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.