Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server running Server 2008 std. and about 10 Wyse C10le that connect to it via RDP. My users are complaining about poor streaming quality and choppy video/audio. Is there anything I can do to increase the quality? I have looked into this and found octoshape, but have not been able to find much on what it does?

share|improve this question

3 Answers 3

You could try and move the Server to use 2008 R2 with RDS. This should allow you to utilize Remote FX, which delivers video much better. You will probably however have to buy some specific cals for your users.

http://technet.microsoft.com/en-us/library/ff817578%28WS.10%29.aspx

share|improve this answer
up vote 1 down vote accepted

UPDATE: After MUCH searching I finally found the answer to this freaking problem. Here is the link: http://www.cyberciti.biz/faq/windows-2003-2008-enable-audio-over-rdp/

And the text just in case the post is removed:

To enable sound to be delivered from a 2k8 server (virtual or not, and with or without TS role installed) to any RDP client, the following steps are needed.

  1. Change the properties of the Windows Audio service on the 2k8 box so that it’s start mode is “Automatic”. Do the same for the Windows Audio Endpoint service. Start both services. This is probably already done if the box is a physical one and a sound card is installed. It won’t already be done if the box is a virtual.

  2. Log out and back in. You will now be presented with a different error on your speaker Icon “No Audio Output Device is installed”. This is because RDP exports your sound card, but not your speaker connections and by default, the audio subsystem requires at least one device connected before it enables the audio functions (how f**stupid is that!)

  3. Make a ton of registry changes (repetitive and redundant, but necessary) a. run regedit and locate the following key. You must be logged in as an Administrator to do this: HKEY_CLASSES_ROOT\AudioEngine\AudioProcessingObjects it will contain several subkeys each named with a GUID b. for each subkey: Click on the subkey. Then right click and select “Permissions”. Click on the Advanced button, then click on the “Owner Tab”. The current owner will show as “TrustedInstaller”. Select your Administrative account or group from the list, and click OK to change the ownership. Select the account you just gave ownership to (Administrator or the administrative group), and click on the “Full Contol” checkbox, then click OK. In the detail box, double click on the DWORD value MinOutputConnections. Change the value from 1 to 0 and click OK. Repeat for each and every subkey in the group.

share|improve this answer

Have you tried enabling the Quality Audio/Video feature in WS08? I am not 100% sure that it is there in 08, I know it's there in 08R2, but it enables QOS for A/V applications.

There's also a registry tweak that you can perform in addition. Should help prioritize A/V applications. [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Multimedia\SystemProfile] "SystemResponsiveness"=dword:00000014

share|improve this answer
    
Couradical, thank you for your response, I changed the SystemResponsiveness to 20 (it was set at 100) and I also changed the NetworkThrottlingIndex to ffffffff (wide open). I'll reboot the server and we'll see how it works tomorrow morning. –  msindle May 24 '11 at 6:03
    
The changes I made earlier do not seem to have made a difference. Does anyone have any more suggestions? –  msindle May 24 '11 at 13:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.