Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We are just about done with our migration from Exchange 2003 to 2010. I have a user who has been migrated to the new system that is now out on medical leave. He has gone into OWA and set up his Out of Office notification. The good news is that an Out of Office message is sent, the bad news is that it appears to be sending an old outdated message from back when the user was on Exchange 2003, and not honoring the new message set up in OWA. The user has also tried setting this up in Outlook 2010 as well with the same behavior. I have a feeling that this is related to the old public folders (didn't they contain OOF messages?) still lingering around our Exchange org. Any ideas?

share|improve this question
add comment

3 Answers 3

up vote 3 down vote accepted

Try opening Outlook with the switch /cleanrules

http://office.microsoft.com/en-us/outlook-help/command-line-switches-for-outlook-2010-HP010354956.aspx

share|improve this answer
    
Thanks for this. This is what fixed the issue for us. It looks like it must have been some old or corrupt rule. –  Tatas May 23 '11 at 15:33
    
Glad this worked for you. –  KCotreau May 23 '11 at 16:00
add comment

I had the same issue following migration from Outlook 2007 to Outlook 2010. The same fix worked from the client i.e. in RUN issue the cmd "outlook.exe /cleanrules". The only problem was it did exactly what it said - i.e. it cleaned all rules - so I had to reset my mailbox rules.

share|improve this answer
add comment

Have they changed both messages?

Exchange 2010 has the concept of Internal and External messages, and when a mailbox is moved from Exchange 2003 to Exchange 2010 the OOF message is copied to both the Internal and External messages.

If the user only changed one of their out of office messages but neglected the other, that would explain it. You can check the out of office message values for the user with the cmdlet Get-MailboxAutoReplyConfiguration username in the Exchange Management Shell.

share|improve this answer
    
Yes, they have changed both external and internal. I can see this from the output of the command you suggested. Still the old outdated message from the exchange 2003 days gets sent instead. –  Tatas May 20 '11 at 21:29
    
Does turning the automatic replies off for the user and re-enabling them help at all? Set-MailboxAutoReplyConfiguration username -AutoReplyState Disabled and then Set-MailboxAutoReplyConfiguration username -AutoReplyState Enabled –  Ben Pilbrow May 20 '11 at 21:33
    
Nope. Tried that. It seems like it's looking in a legacy spot (old PF?) for the data when it shouldn't be. –  Tatas May 20 '11 at 21:39
    
Definitely weird, but I don't believe it will be looking in the PF's because they are optional (Microsoft are also trying their hardest to get rid of them) and OOF works without them. Does setting the message using the shell make any difference at all? Also, is it just the one user, a handful of them or everyone? –  Ben Pilbrow May 20 '11 at 21:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.