Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Possible Duplicate:
“<handler> scriptProcessor could not be found in <fastCGI> application configuration” when accessing PHP script in subfolder

I have a configuration problem with php on IIS 7.5.

It is a practically fresh install made with the MS Web PI on Win7.

I created a simple php testpage. It works in the root level http://localhost/test.php and in the first sub-level http://localhost/site/test.php, but not in http://localhost/site/subfolder/test.php, there I get HTTP 500 error:
<handler> scriptProcessor could not be found in <fastCGI> application configuration

Everything seems to be configured as specified in http://www.iis.net/ConfigReference/system.webServer/fastCgi/application

Could there be some kind of filter that disables processing at specific folder-level / or enable it just in the first 2 levels?

What should I check?

share|improve this question

migrated from stackoverflow.com May 20 '11 at 23:31

This question came from our site for professional and enthusiast programmers.

marked as duplicate by Chopper3 Jun 17 '11 at 19:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 1 down vote accepted

Turns out I copied the files that I had on the previous setup. And the subfolder that was not working had web.config where a different php-cgi.exe was specified.

Basically I now have 64-bit system and the php executable is in C:\Program Files (x86)\PHP\v5.3\php-cgi.exe, I discovered it in the IIS Manager by going to the non-working folder and opening Handler Mappings and checking the value for PHP_via_FastCGI, that's when I noticed the old executable in C:\Program Files\PHP...

Thanks for your attention :) hope this helps someone.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.